Incorrect Date Ordering of Emails in Exchange/Microsoft 365 After Migrating From Google Workspace

Problem

If you migrated to Google Workspace in the past, then migrated back to Exchange or Microsoft 365, you may see incorrect dates on emails.

Diagnosis

Exchange orders by 'Received' rather than by 'Date'. When you migrate to Google Workspace, Gmail always adds another 'Received' header. So we have introduced a setting that can solve the problem.

In the destination platform Advanced Settings see: Message Options > Strip Received HeadersThis will remove the received headers from the email and replace them with a single header corresponding to the date header of the email.  Exchange will then order the email in the Date order as expected.

Was this article helpful?
0 out of 0 found this helpful